How to Report Bugs / List of Known Bugs

seaturtle

Spirit Bridge
Administrator
Rainbow Rocket Executive
Join Date
Oct 23, 2018
Posts
1,632
AKA
Chris
Gender
Male
Time Zone
MST
Switch FC
SW-3906-8627-4487
How to Report Bugs
If you are experiencing any bugs here on Marriland, this is the thread to report and discuss them, as well as view already existing issues. Before you post, please look through the List of Known Bugs below to make sure what you are experiencing is not already listed.

Once you have done so and you are ready to report your bug(s), please use the form below and post here:
  • What is happening for you?:
  • What led up to your issue? Can it be recreated?:
  • When did this start happening?:
  • Which internet browser are you using? Do you know if it is happening on other browsers?:
  • Are you on a mobile device, or do you know if it is occurring on mobile devices?:
  • Relevant screenshot(s) if applicable:
List of known bugs:
Badges Do Not Show Up Immediately After Being Added
When a user is given a badge, it does not immediately appear on their profile like it should. However, the badge will eventually appear as the system processes it.

Users Aren't Receiving Emails from the Forums
Some email providers seem to be having problems with receiving emails from the forums. This has been happening with AOL and Yahoo email addresses. We are working on getting this addressed, but for the time being we recommend that you change your account's email to a different provider until we are able to get it resolved.

Some .gif Avatars Don't Display Properly
Some animated (.gif) avatars have issues displaying correctly. We are currently unable to address this issue, unfortunately.
 
Last edited:

Matthew

Tech Enthusiast
Join Date
Nov 1, 2018
Posts
32
Gender
Male
Time Zone
Central
The section that displays the last in the forum has an unnecessary CSS rule that shouldn't be there. The username is not inline with the rest of the text, instead it shows below it.

Here is what it looks like now, on desktop and mobile.
m2.png
Screenshot_2018-11-01 Marriland Forums.png



Should look like this on desktop and mobile.
m3.png
Screenshot_2018-11-01 Marriland Forums(1).png



The unnecessary CSS rule in question, is this:

Code:
.node-extra-user {
    display: flex !important;
}
If you disable it, you can see that it goes back to normal.

m1.png
 
Last edited:

Thundawave

♔ Deja Vu ♔
Staff Emeritus
Rainbow Rocket Grunt
Join Date
Oct 23, 2018
Posts
1,114
Location
Nowhereville
AKA
Thunda, Regine
Gender
Female
Time Zone
EST
3DS FC
4184-1904-4290
Switch FC
SW-2896-2294-7693
IGN
Regine
This is intentional. Before they were implemented, usernames overflowed and cut off after a certain width was reached. We’re still figuring out how to get rid of the bullet point to make it look smoother though.
 

Matthew

Tech Enthusiast
Join Date
Nov 1, 2018
Posts
32
Gender
Male
Time Zone
Central
This is intentional. Before they were implemented, usernames overflowed and cut off after a certain width was reached. We’re still figuring out how to get rid of the bullet point to make it look smoother though.
That's a fair point for desktop, but on mobile it's important to save space. Try this:

Code:
@media (max-width: @xf-responsiveMedium) {
    .node-extra-user {
        display: inline !important;
    }
}
What @media (max-width: @xf-responsiveMedium) does, is allow you to change CSS for different viewpoints on mobile devices. That will change the CSS for small tablets to phone sizes.
 

seaturtle

Spirit Bridge
Administrator
Rainbow Rocket Executive
Join Date
Oct 23, 2018
Posts
1,632
AKA
Chris
Gender
Male
Time Zone
MST
Switch FC
SW-3906-8627-4487
Just added another bug to the list, but for some reason emails from the forums aren't getting through to Yahoo email addresses. If anyone else is having problems with other email providers, let an administrator know and we'll keep on looking into it. We're working on getting this resolved as soon as we can.

[Edit] Also @Matthew, I've carried out the changes that you've suggested. Thanks for the help! c:
 
Last edited:

Thundawave

♔ Deja Vu ♔
Staff Emeritus
Rainbow Rocket Grunt
Join Date
Oct 23, 2018
Posts
1,114
Location
Nowhereville
AKA
Thunda, Regine
Gender
Female
Time Zone
EST
3DS FC
4184-1904-4290
Switch FC
SW-2896-2294-7693
IGN
Regine
Users are able to edit their own polls, lock/unlock their own threads, and move their own threads. I've deleted the mention about the inability to do so on the first post. :D
 

colours

Regular Trainer
Join Date
Nov 1, 2018
Posts
177
AKA
Angie/Angelica
Gender
Female


Issue: gif avatars aren't displaying correctly; at least sprite ones.

What lead up to your issue? Can it be replicated? Just uploading a regular ol' sprite gif avatar seems to do the trick in creating this bug. :c I guess anyone else is free to try using their own if they have one. This may or may not be something just unique to sprite avatars, but considering those are mainly the avatars that I use, it'd be a huge bummer if I were forced to pick something else.

When did this start happening? Ummm... yesterday, when I tried.

Browser stuff: I currently use Chrome, but the issue is visible in Firefox, as well. The odd thing is that in the avatar editor, it shows up perfectly fine with no issues, so I'm not sure what could be the cause of this. :c

Mobile Device? No.

Screenshot? https://gyazo.com/5a4c6d0afcb074fbb1ae9138ccf8dabb
 

seaturtle

Spirit Bridge
Administrator
Rainbow Rocket Executive
Join Date
Oct 23, 2018
Posts
1,632
AKA
Chris
Gender
Male
Time Zone
MST
Switch FC
SW-3906-8627-4487
It seems like this might be an issue involving how the forums resize gif avatars when you upload them. It could also be an issue with the gifs themselves being in some sort of weird format that the site doesn't like. It doesn't seem to be an issue with all gifs because other members have used them with no noticeable problems. Unfortunately it doesn't look like we'll be able to address it (at least with what we know right now), but thank you for reporting it. I'll add it to the top post, and if you figure out a way to get the images to work let us know.
 

Petros

Pokémon Trainer
Rainbow Rocket Grunt
Join Date
Mar 28, 2019
Posts
40
Gender
Male
What is happening for you?: Images won't resize.

What led up to your issue? Can it be recreated?: Yes, it can be recreated. Insert the URL of an image between [ IMG ] tags and try to resize it using the button that pops up when you click on the image. After doing so, choose the new width and height. Press ok and, apparently, the image has resized (or so that looks in the preview), but when you send the post, it remains unchanged.

When did this start happening?: Today

Which internet browser are you using? Do you know if it is happening on other browsers?: I'm using Firefox. I'm not sure if it's on my end or a general problem, that's why I'm reporting it.

Are you on a mobile device, or do you know if it is occurring on mobile devices?: Haven't tried with my phone, sorry.

Thank you :D
 

seaturtle

Spirit Bridge
Administrator
Rainbow Rocket Executive
Join Date
Oct 23, 2018
Posts
1,632
AKA
Chris
Gender
Male
Time Zone
MST
Switch FC
SW-3906-8627-4487
This is actually one of those features that I didn't know existed until now, so uh 👀 thanks for bringing it up! We're relatively new to the forum software so we're still getting used to everything.

It appears to be working fine for me, but could you try checking the raw BB code of the post after you edit it? You can do that by clicking the little gear icon in the editor. If you're editing the width/height by dragging it, it should be changing the BB code to look something like this: [IMG width="100px"]image url here[/IMG]
 

Petros

Pokémon Trainer
Rainbow Rocket Grunt
Join Date
Mar 28, 2019
Posts
40
Gender
Male
This is actually one of those features that I didn't know existed until now, so uh 👀 thanks for bringing it up! We're relatively new to the forum software so we're still getting used to everything.

It appears to be working fine for me, but could you try checking the raw BB code of the post after you edit it? You can do that by clicking the little gear icon in the editor. If you're editing the width/height by dragging it, it should be changing the BB code to look something like this: [IMG width="100px"]image url here[/IMG]
Haha, I gues I'm just too curious and love clicking on everything XD

Yes, I did try that and the BB Code didn't change at all, although I could see the image changed size, the BB Code remained unaltered. But if you're able to get it working, I suppose it's because of my browser.
 

seaturtle

Spirit Bridge
Administrator
Rainbow Rocket Executive
Join Date
Oct 23, 2018
Posts
1,632
AKA
Chris
Gender
Male
Time Zone
MST
Switch FC
SW-3906-8627-4487
This is actually one of those features that I didn't know existed until now, so uh 👀 thanks for bringing it up! We're relatively new to the forum software so we're still getting used to everything.

It appears to be working fine for me, but could you try checking the raw BB code of the post after you edit it? You can do that by clicking the little gear icon in the editor. If you're editing the width/height by dragging it, it should be changing the BB code to look something like this: [IMG width="100px"]image url here[/IMG]
Haha, I gues I'm just too curious and love clicking on everything XD

Yes, I did try that and the BB Code didn't change at all, although I could see the image changed size, the BB Code remained unaltered. But if you're able to get it working, I suppose it's because of my browser.
I just downloaded Firefox to test it out and it was still working for me, which is really strange... I can't figure out why it's behaving that way for you, but I'll keep poking around and see if I can find something. In any case, resizing images using BB code like the one I mentioned earlier should still work, so for now hopefully you can get around the bug by using that.
 

~Kilza~

The Sun Has Set
Rainbow Rocket Grunt
Account Disabled
Join Date
Oct 28, 2018
Posts
9,132
Location
Gone forever
Gender
Male
Time Zone
MST (UTC-7)
But if you're able to get it working, I suppose it's because of my browser.
Just wondering, but what version of Firefox are you running? Since I have the latest (v66.0.2) and it's running fine, and I imagine that's the version Bubba downloaded and used as well.

e: Also, which OS do you use? Since I'm on Windows 10 and, again, it runs fine on it.
 
Last edited:

Petros

Pokémon Trainer
Rainbow Rocket Grunt
Join Date
Mar 28, 2019
Posts
40
Gender
Male
This is actually one of those features that I didn't know existed until now, so uh 👀 thanks for bringing it up! We're relatively new to the forum software so we're still getting used to everything.

It appears to be working fine for me, but could you try checking the raw BB code of the post after you edit it? You can do that by clicking the little gear icon in the editor. If you're editing the width/height by dragging it, it should be changing the BB code to look something like this: [IMG width="100px"]image url here[/IMG]
Haha, I gues I'm just too curious and love clicking on everything XD

Yes, I did try that and the BB Code didn't change at all, although I could see the image changed size, the BB Code remained unaltered. But if you're able to get it working, I suppose it's because of my browser.
I just downloaded Firefox to test it out and it was still working for me, which is really strange... I can't figure out why it's behaving that way for you, but I'll keep poking around and see if I can find something. In any case, resizing images using BB code like the one I mentioned earlier should still work, so for now hopefully you can get around the bug by using that.
Yes, I’m okay with using the BB Code, thanks!
But if you're able to get it working, I suppose it's because of my browser.
Just wondering, but what version of Firefox are you running? Since I have the latest (v66.0.2) and it's running fine, and I imagine that's the version Bubba downloaded and used as well.

e: Also, which OS do you use? Since I'm on Windows 10 and, again, it runs fine on it.
Yes, that’s the version I’m using too. I’ve been having some troubles since I updated Firefox last time, that’s why I think it’s on my end but wanted to make sure it wasn’t a bug or something. I use Linux Mint 19 btw.
 

Typhlosion

Tempered Steel
Moderator
Rainbow Rocket Executive
Cult Classic
Join Date
Oct 23, 2018
Posts
1,985
Location
Olivine City
AKA
Ben, A_T
Gender
Male
Time Zone
US Central (GMT -6:00)
3DS FC
2724-0144-2557
IGN
Ben
My signature is not displaying correctly for a reason I can't figure out. The BBcode appears to be intact and I haven't touched it for weeks, but I opened up the site today and the image is simply not there.
 

~Kilza~

The Sun Has Set
Rainbow Rocket Grunt
Account Disabled
Join Date
Oct 28, 2018
Posts
9,132
Location
Gone forever
Gender
Male
Time Zone
MST (UTC-7)
That's on Bulbagarden, not the forums.


For the record, it's always shown up as a broken image to me. I'd just grab and re-host the image on something like Imgur.
 

Typhlosion

Tempered Steel
Moderator
Rainbow Rocket Executive
Cult Classic
Join Date
Oct 23, 2018
Posts
1,985
Location
Olivine City
AKA
Ben, A_T
Gender
Male
Time Zone
US Central (GMT -6:00)
3DS FC
2724-0144-2557
IGN
Ben
Thanks! Back for me. How's that look to you @~Kilza~ ?
 

~Kilza~

The Sun Has Set
Rainbow Rocket Grunt
Account Disabled
Join Date
Oct 28, 2018
Posts
9,132
Location
Gone forever
Gender
Male
Time Zone
MST (UTC-7)
It actually shows an image now so that's a huge improvement, lol
 
Top